Copyright © 2020 Indica Labs Inc.

Indica labs is committed to the continuous improvement and technical innovation of the HALO software platform and associated analysis modules. We therefore retain the right to deviate from the information, descriptions and specifications provided within this publication as such improvements are enacted. Indica labs shall not be liable for any errors contained within this publication or any loss of data or damages that occur as a result. It is not permitted to reproduce or transmit any part of this publication without the expressed consent of Indica labs. For additional online training materials, join our online learning portal.

For additional support contact support@indicalab.com or reach out directly for local support as needed.

Main office

Indica Labs Inc
8700 Education Pl NW Bldg. B
Albuquerque New Mexico, 87114
Tel +1 (505) 492-0979
www.indicalab.com

Indica Labs provides direct support in the following regions:

Europe          Japan          China
+44 (0)1789 765 721  +81 (0)70 4180 7730  +86 13761896143
emea@indicalab.com japan@indicalab.com china@indicalab.com
# Table of Contents

1. **Introduction** ........................................................................................................................................................................ 1
   - Supported File Types ......................................................................................................................................................... 1
   - Viewer Interface ................................................................................................................................................................. 1
     - Navigation Menu .......................................................................................................................................................... 1
     - Tabs .................................................................................................................................................................................. 2
     - Studies Pane ................................................................................................................................................................. 2
     - Slide Pane ................................................................................................................................................................. 2
   - Viewing Window ............................................................................................................................................................... 2
   - Help .................................................................................................................................................................................. 3

2. **Image Management** .......................................................................................................................................................... 3
   - Open Images ................................................................................................................................................................. 3
     - Set Image Resolution .................................................................................................................................................. 3
   - Organize Images in Studies ........................................................................................................................................... 4
   - Create a Study ............................................................................................................................................................... 4
   - Rename a Study ............................................................................................................................................................. 4
   - Delete a Study ............................................................................................................................................................... 4
   - Move a Study ................................................................................................................................................................. 4
   - Folder Monitoring .......................................................................................................................................................... 4
   - Database Backup ......................................................................................................................................................... 5
   - Integration with Image Management Systems ......................................................................................................... 5

3. **Image Viewing** ............................................................................................................................................................... 5
   - Image Tabs ................................................................................................................................................................. 5
   - Change the Skin ............................................................................................................................................................. 5
   - Pan Tool ........................................................................................................................................................................ 6
   - Zoom Toolbar ............................................................................................................................................................. 6
   - Navigate with the Thumbnail ........................................................................................................................................ 6
   - Toggle the Slide Label, Scale Bar, and Thumbnail .................................................................................................... 6
   - Image Orientation ......................................................................................................................................................... 7
   - Label Rotation ............................................................................................................................................................. 7
   - Fuse Images ................................................................................................................................................................. 7
     - Fuse Channels .......................................................................................................................................................... 7
     - Fuse QPTiffs ............................................................................................................................................................ 8
   - View Settings .............................................................................................................................................................. 9
     - Apply View Settings to a Batch of Images ............................................................................................................... 9

4. **Annotations** ................................................................................................................................................................. 10
   - Layers ............................................................................................................................................................................. 10
   - Toolbar ....................................................................................................................................................................... 11
   - Annotation Modification .............................................................................................................................................. 12
   - Annotations Manager ............................................................................................................................................... 13
   - Import & Export .......................................................................................................................................................... 13
   - Annotation Shortcuts ............................................................................................................................................... 13
   - Manual Counter .......................................................................................................................................................... 14
   - Advanced Annotation Tools ...................................................................................................................................... 14
1. Create Plots ............................................................................................................................................................................. 27
2. Delete Results ........................................................................................................................................................................ 26
3. Export Data ............................................................................................................................................................................. 25
4. Object Data ............................................................................................................................................................................. 23
5. Batch Mode Analysis ........................................................................................................................................................... 23
6. Live Mode Analysis .............................................................................................................................................................. 22
7. Save Tuned Analysis Settings .......................................................................................................................................... 22
8. Adjust Analysis Parameters .............................................................................................................................................. 21
9. Load Analysis Settings.......................................................................................................................................................... 21
10. Import Analysis Settings ................................................................................................................................................. 21
11. Advanced Settings ............................................................................................................................................................... 18
12. Join .......................................................................................................................................................................................... 16
13. Tiled Partitioning ............................................................................................................................................................... 15
14. Margins .................................................................................................................................................................................... 15
15. Concentric Partitioning .................................................................................................................................................... 15
16. Layer Thickness ................................................................................................................................................................. 15
17. HALO 3.1 User Guide
18. Batch Mode ............................................................................................................................................................................. 17
19. Edit Registration with Landmarks ........................................................................................................................................ 17
20. Annotations on Registered Images ...................................................................................................................................... 18
21. Advanced Settings ............................................................................................................................................................... 18
22. 5. Image Registration .......................................................................................................................................................... 16
23. Individual Histograms ..................................................................................................................................................... 29
24. Batch Spatial Plots ............................................................................................................................................................ 29
25. Individual Spatial Plots .................................................................................................................................................... 27
26. Batch Mode ......................................................................................................................................................................... 27
27. Advanced Export ............................................................................................................................................................... 26
28. Basic ........................................................................................................................................................................................ 25
29. Filter Object Data .............................................................................................................................................................. 24
30. Save Object Data Filters .................................................................................................................................................. 25
31. Export Data ............................................................................................................................................................................. 25
32. Basic ........................................................................................................................................................................................ 25
33. Batch Mode ......................................................................................................................................................................... 25
34. Advanced Export .............................................................................................................................................................. 26
35. Delete Results ........................................................................................................................................................................ 26
36. Basic ........................................................................................................................................................................................ 26
37. Batch Mode ......................................................................................................................................................................... 27
38. Create Plots ........................................................................................................................................................................... 27
39. Individual Spatial Plots .................................................................................................................................................... 27
40. Batch Spatial Plots ............................................................................................................................................................ 29
41. Individual Histograms .................................................................................................................................................... 29
42. 10. HALO Shortcuts .......................................................................................................................................................... 31
43. 11. HALO Viewer .............................................................................................................................................................. 33
1. Introduction

HALO is the gold standard image analysis platform for quantitative tissue analysis in digital pathology. With unmatched ease-of-use and scalability, powerful analytic capabilities, and the fastest processing speeds available for digital pathology, pharmaceutical, healthcare and research organizations worldwide are using HALO for high-throughput, quantitative tissue analysis in oncology, neuroscience, metabolism, toxicology and more.

Join our Learning Portal for up to date user guides, training videos, webinars, and more!

For additional support, contact support@indicalab.com.

Supported File Types

- Non-Proprietary (JPG, TIF)
- 3D Histech (MRXS)
- Perkin Elmer (QPTIFF, component TIFF)
- Aperio (SVS, AFI)
- Leica (SCN, LIF)
- DICOM (dcm)**
- Open Microscopy (OME.TIFF)
- Nikon (ND2)*
- Olympus (VSI)
- Hamamatsu (NDPI, NDPS)
- Zeiss (CZI)
- Ventana (BIF)
- KFBio (KFB)

*Pyramidal tiffs are required for whole slide image viewing. Whole slide ND2 files are not pyramidal and the entire image must be stored in memory which may cause issues with HALO software.

**Initial implementation starting with the HALO 3.1 release.

Viewer Interface

Navigation Menu

File – Open new or recent images and save snapshots of the viewing window.

Tools – Access tools such as Figure Maker, Manual Counter, Image , Image Registration and Fuse Images.
View – Toggle the Slide Label, Scale Bar, and Thumbnail, open the analysis jobs window, change image View Settings, and Change the Skin.

Help – View HALO details, reference forms, user manual, and module specific user guides.

**Tabs**

**Studies Tab** – Load and organize images into studies. Batch processing is launched from this tab.

**Annotations Tab** – Create and modify annotation layers.

**Analysis Tab** – Load and tune algorithm parameter settings.

**Results Tab** – View summary results, object results, and plots (if applicable) after analysis.

*Note:* If the tissue microarray (TMA) or classifier modules are purchased, a tab for each of these will also be visible.

**Studies Pane**

Displays the structure of the study folders and subfolders. The Study Actions button allows studies to be created, renamed, moved or deleted. Studies can be sorted in ascending or descending alphabetical order or by creation date using the drop-down box to the right of the Study Actions button. The search bar searches the text of all study names. The entire study tree is displayed if the searched study is a substudy. Only displayed when the Studies tab is active.

If HALO is used with HALO Link integration enabled, users are only able to view and modify studies as their permission status allows. A refresh button ( ) next to the study search box allows users to sync to the shared database as needed.

**Slide Pane**

Displays the individual slides/images in the study selected in the studies pane. The analysis column indicates the state of the analysis. If the analysis column is blank, no analysis was run. The last column indicates if an image has at least one annotation layer ( ) or a registration ( ) associated. The Image Actions allows images to be opened, renamed, analyzed, moved, exported, or deleted. The search bar searches the text of all image tags and paths in the highlighted study. Only displayed when the Studies tab is active. allows images to be opened, renamed, analyzed, moved, exported, or deleted. The search bar searches the text of all image tags and paths in the highlighted study. Only displayed when the Studies tab is active. allows images to be opened, renamed, analyzed, moved, exported, or deleted. The search bar searches the text of all image tags and paths in the highlighted study. Only displayed when the Studies tab is active.

**Viewing Window**

Opened slides are displayed in this window. Slides are tabbed by default.
Help
PDF user guides for the installed version of HALO and relevant analysis modules are found under the Help menu in the main navigation menu. A quick reference popup is also accessible in this help menu. Keyboard shortcuts and an icon legend are included in this popup.

These guides are a useful starting point, but additional questions ranging from IT support to specific algorithm setup questions can be sent to support@indicalab.com. When emailing, please tell us what institution you are with and include a snapshot of the about section to aid us in quickly responding to your question. The about section is also found in the Help menu.

2. Image Management

Open Images
- Click File in the navigation menu.
- Select Open images... from the.
- In the pop-up window, select the image files to open.
- To open multiple images in a folder, hold down the Ctrl key while left-clicking on the images to open.
- To open all images in a folder, hold down the Ctrl + A keys.
- Click the Open button.
- When an image is opened for the first time, the image must be assigned to a study. In the next pop-up window, select the study folder and click the OK button to assign the image to that study.
- Create a new study by clicking on the New Study button in the lower left corner of the pop-up window.
- In the next pop-up window, type the name of the study and click the OK button to create the study folder.

Note: An arrow to the left of the folder indicates subfolders. Click on the arrow to show or hide the subfolders in a selected folder.

Note: If an image is already assigned to a study, the image will open without requesting a folder assignment.

Open an image that is already assigned to a study in one of three ways. First, if multiple images need to be opened, select multiple images to open by holding down the Ctrl key while left-clicking on the image thumbnail. Double-clicking on the image name or thumbnail in the slide pane of the Studies tab is the first method for opening an image. Instead, from the Image Actions drop-down list at the top of the slide window select Open. Alternatively, right-click on the image and select Open from the drop-down menu.

HALO by default duplicates the file name for each image. To rename an image with an image tag, right-click and select Rename... from the drop-down. In the popup, type in the preferred image tag and click OK. When exporting results this image tag is also exported.

Set Image Resolution
This step is typically not necessary because image metadata is imported with the image. If necessary, set the resolution for an image to properly display measurements. The resolution must be set to use the real time tuning window and to add scale bars and measurements to images.

- In the slide pane of the Studies tab, right-click on the image of interest.
- From the drop-down menu, select Attributes.
• Select Set Resolution....
• In the pop-up window, type the number of microns per pixel in the text box.
• Click the **Save** button.

*Note:* This data is imported with most proprietary file types.

### Organize Images in Studies

Images belonging to the same project or experiment are easily organized into studies in the HALO database. Images in a study can be analyzed in batch and the data exported into a single spreadsheet.

Moving an image to the trash study will not erase the image. The image and all data associated with the image (annotations, analysis results, etc.) will remain with the image in the HALO database. Trash is simply a catch all study for images which have not been assigned to a specific study.

#### Create a Study

- In the studies pane of the Studies tab, click on the **Study Actions** button.
- From the drop-down menu, select **New**....
- In the pop-up window, type the name of the study.
- Click the **OK** button to create the study folder.

*Note:* The new study is created in the study folder currently highlighted in the studies pane.

#### Rename a Study

- In the studies pane of the Studies tab, select the study to rename by left-clicking the name.
- Click on the **Study Actions** button.
- From the drop-down menu, select **Rename**....
- In the pop-up window, type the name of the study.
- Click the **OK** button to rename the folder.

#### Delete a Study

- In the studies pane of the Studies tab, select the study to delete by left-clicking on the name.
- Click on the **Study Actions** button.
- From the drop-down menu, select **Delete**....
- In the pop-up window, click the **OK** button.

#### Move a Study

- In the studies pane of the Studies tab, select the study to move by left-clicking on the name.
- Click on the **Study Actions** button.
- From the drop-down menu, select **Move**....
- In the pop-up window, left-click on the new parent folder.
- Click the **OK** button.

#### Folder Monitoring

Monitor a specific folder or folders on the workstation or server to detect certain image file types and automatically add them into HALO. This setup automates the addition of slides into the HALO database immediately after scanning. For more information, contact **support@indicalab.com**.
Database Backup
The HALO database may be backed up to ensure that in the event of hardware failure minimal work is lost.

- Click **Tools** in the navigation menu.
- Select **Options...** from the drop-down menu.
- In the **General Configuration** tab of the pop-up window, click the **Manage Backups** button.
- In the next pop-up window, first select the backup folder location.

*Note*: The backup should not be saved locally but rather to a separate drive or a location on a server.

- Click the **Backup Now** button to immediately backup the database.
- Alternatively, set up weekly or monthly backups at designated times by selecting the appropriate options in the **Scheduled Backups** section of the pop-up window.

*Note*: The time it takes to back up the database varies widely from a couple of minutes to hours. Please take this into account when deciding when to schedule your HALO backup.

*Note*: Classifiers are now stored outside of the MySQL database. Check the ‘Backup Classifier files’ boxes to ensure classifiers can be restored if needed.

Integration with Image Management Systems
Several image management systems can be integrated, including HALO Link. If integrations are enabled, settings are viewed under **Tools > Options**. For more information, contact support@indicalab.com.

3. Image Viewing

Image Tabs
When multiple images are opened, the images are tabbed by default. To view images side by side, right-click on the tab containing the image name and select **Tile All Tabs Horizontally** or **Tile All Tabs Vertically** from the drop-down menu. To restore images to the tabbed default, right-click on the image name tab and select **Move to Previous Tab Group** from the drop-down menu. Alternatively, tabs may be arranged by left-clicking and dragging the image window to a different tab group. To close all open images at one time right-click on one of the tabs, select **Close All Documents**.

Image windows can float outside of the HALO interface. To float images, right-click on the image name tab above the image and select **Float** from the drop-down menu. Left-click the image name tab and drag the floated image to a new location or monitor.

Change the Skin
Select between a dark or light interface background.
From the navigation menu, left-click **View** and mouse over **Skin**. Select **Light** or **Dark** to select the white or dark grey background, respectively. The skin color will change immediately.

**Pan Tool**
The hand icon button ( ) on the toolbar in the lower right corner of the viewing window is the pan tool. This tool allows panning around the image in the viewing window by left-clicking and dragging. Alternatively, use the arrow keys on the keyboard to navigate around the image.

**HALO Tip**: Right-clicking and dragging will always pan around the image, regardless of toolbar selection.

**Zoom Toolbar**
Zoom controls located in the bottom left corner of the viewing window. The first button ( ) allows the user to toggle between normal viewer mode and full screen mode. If a dual monitors setup is utilized, the image is maximized in the primary monitor. The next button ( ) changes the image magnification to allow the entire image to fit the viewing window. The set points on the zoom slider bar (1X, 2X, 5X, 10X, ...) change to zoom to a set magnification. The maximum zoom is equivalent to the capture magnification. Double-click the left mouse button anywhere in the image to go to full magnification. Alternatively, use the mouse scroll wheel to zoom in and out of the image. The image magnification is displayed to the right of the zoom slider.

**Note**: For images with unknown resolution, magnification values are replaced with percentages.

**HALO Tip**: Hold down the **CTRL** key when zooming in to zoom pass the maximum image resolution.

**Navigate with the Thumbnail**
Click anywhere in the macro thumbnail in the upper right corner of the viewing window to navigate to a specific area of the image. The transparent grey box at the intersection of the green lines indicates the location of the current field of view. Change the size of the thumbnail by left-clicking and dragging the lower left corner.

**Toggle the Slide Label, Scale Bar, and Thumbnail**
Hide or display the label image, macro thumbnail, or scale bar by selecting View from the navigation menu and clicking Slide Label, Slide Thumbnail, and Slide Scale Bar from the drop-down menu. When check marked, the label, thumbnail, or scale bar will be displayed and when uncheck marked, the label, thumbnail, or scale bar will be hidden.

Image Orientation
Rotates and reflects images.

- Click Tools on the navigation menu.
- Select Image Orientation... from the drop-down menu.
- In the pop-up window, use the slider to rotate the image 180 degrees around the image center point either direction. Alternatively, type the degree of rotation directly into the text box.
  - Move the slider to the left or type in negative values to rotate clockwise.
  - Move the slider to the right or type in positive values to rotate counterclockwise.
- The image can be reflected across a horizontal axis or vertical axis by selecting either button in the pop-up window.
- Click the Apply Orientation button to apply the changes and close the pop-up window.
- To return to the original orientation, select the Reset Orientation button and the window will close automatically.

Note: All image orientation changes should be performed PRIOR to analysis.

Note: Image annotations will also be rotated and/or reflected after clicking Apply Orientation.

Label Rotation
- To rotate an image label, hover the cursor over the label in the viewing window. Left-click to rotate 90 degrees.
- To rotate labels for a batch of images, select all images from the image panel. Right-click and select Image Details, then Set Label Rotation. The Set Label Rotation window will open. Left-click on the example label to rotate 90 degrees to desired orientation, then Save.

Fuse Images
Fuse Channels
Fuses images of individual fluorescence channels into a single multilayer image for analysis.

- Click Tools from the navigation menu.
- Select Fuse Images > Fuse Channels... from the drop-down menu. A fuse images window containing a list of the currently opened images will open.
- Use the Add Images button to add additional channels/images.
- Delete channels by clicking the X button to the left of the image path.
- Under channel name, label each channel something easily recognizable for analysis like DAPI.
- Select the appropriate color for each channel from the drop-down lists.
- If the Remove channel images box is checked, the individual image channels will be removed from the list of images in the study. Uncheck this box to keep the individual images in the HALO database.
- Click the Fuse button to fuse the images to create a multilayer image.
Fuse QPTiffs
Fuses multiple spectrally unmixed field of view images from the Akoya (previously Perkin Elmer) Vectra/Polaris scanner into a single multilayer image for analysis.

If all images to be fused (and only those images to be fused) are open in HALO viewer...

- Click **Tools** from the navigation menu.
- Select **Fuse Images > Fuse QPTiffs** from the drop-down menu. A save as window will open.
- Specify an image name and folder. Click the **Save** button. **Users must have write permissions to the selected folder.** A Fuse QPTiffs dialog will track the progress.
- Once finished, the **Select Study** dialog box will pop up.
- Assign the new image to the appropriate study/substudy and click **OK**.

If all images to be fused are **not** open in HALO viewer...

- Go to the Studies tab.
- In the image pane, select the images to fused.
- From the **Image Actions**, select **Fuse > Fuse QPTiffs**... A save as window will open.
- Specify an image name and folder. Click the **Save** button. Users must have write permissions to the selected folder.
- A Fuse QPTiffs dialog will track the progress. Once finished, the **Select Study** dialog box will pop up.
- Assign the new image to the appropriate study/substudy and click **OK**.

*Note:* A new multilayer tif file is written in this process which may take time for large images.

*Note:* The related `.qptiff` file may be fused with the spectrally unmixed fields of view but is not required.
**View Settings**
Changes the view settings of an image.

- After opening an image, click **View** from the navigation menu.
- Select **View Settings...** from the drop-down menu. A view settings window will open.
  
  **Note:** Alternatively, for fluorescent images, click on the button in the upper left corner of the channel box.
- Select a specific channel to change by clicking the drop-down to the left of the image name to select the channel. Select All to apply changes to every channel in the image.
- Use the sliders under the histogram or type a number directly into the **Black In:** or **White In:** text box. Alternatively, left-click on the graph to set the **White In** value (pink vertical line).
- Changes in view settings are applied to the active image in real time.
- Close the window to keep the changes or click the **Reset** button to reset settings.
- The **Metadata...** button opens a popup window to display the image bit depth, size, resolution, and number of channels (if fluorescent).
  
  **Note:** The maximum White In value scales to the image bit depth (255 for 8 bit, 65,535 for 16 bit).
  
  **Note:** Some file formats (often 32-bit floating-point files) include a White In value as a tif tag for each channel. When present, the image view settings take this value into account.

**Apply View Settings to a Batch of Images**
- After changing the view settings for an image, click the **Export...** button.
- In the pop-up window, select a name and location for the `.viewsettings` file.
- In the Studies tab, select the appropriate batch of images. Hold down the **Ctrl** key while clicking to select multiple images.
- Right-click on the highlighted image names and select **Import > View Settings** from the menu.
- In the pop-up window, select the appropriate `.viewsettings` file and click the **Open** button.
- Upon successful import, **View Settings Imported Successfully** will be displayed.
  
  **Note:** Changing the view settings does not change image data and will not affect analysis results.
4. **Annotations**

Annotations identify specific regions to include or exclude from analysis. Click on the **Annotations** tab to view and manage annotations. The annotations pane contains the length, area, and type information for the annotations in the active annotation layer of the image. The annotation table can be sorted by any of these attributes by left-clicking on any of these headers. Annotations selected in either the viewing window or the annotations pane will be highlighted in the other area.

Measurements from the annotations window may be copied and pasted into a spreadsheet for further analysis.

![Annotations example](image)

Figure 8 – Annotations example. This slide has two annotation layers. Layer one, shown in yellow, and layer two, shown in green. The yellow layer consists of a large inclusion area, a smaller exclusion area, a square inclusion area, an ellipse exclusion area, and a ruler measurement sorted in the annotations pane based on area. The green layer consists of a large inclusion area and a smaller exclusion area. Inclusion areas are depicted as solid lines and exclusion areas depicted as dashed lines.

Multiple annotations are selected by holding down the `Ctrl` key while left-clicking on the annotations. Press `Ctrl+C` to copy the selected annotation measurements or right-click and select `Copy` from the popup menu. Open a spreadsheet. Press `Ctrl+V` or right-click in a cell and select `Paste` from the drop-down menu.

Alternatively, all annotation measurements from an image may be exported together. In the Studies tab, right-click on the image(s) of interest. From the, select `Export...` followed by `Annotation Measurements`. In the pop-up window, name the csv file and select the saved file destination. Click the `OK` button. The export file contains information about the annotation layer name, region index, perimeter, area.

Click the **Save Annotations** button at the top of the Annotations tab to save completed annotations. If an image is closed before saving new or modified annotations, a pop-up window will ask the user if they want to save the annotations.

**Layers**

Annotations can be organized into groups using annotation layers. Navigate between layers using the drop-down annotations layer drop-down list above the annotation pane.
Annotation layers are managed in the Annotations tab, using the **Layer Actions** drop-down menu above the annotations pane. To add a new layer, select **New Layer** from this menu. Delete current layers by selecting **Delete Layer...**, **Delete All Layers...**, or **Delete All But Current...** from this drop-down menu. Additionally, hide annotations by toggling **Visible** on and off in this menu.

Change the layer name and color to easily distinguish different annotation layers. Layers are given generic names and colors (Layer 1, Layer 2, etc.), but **Rename...** and change the **Color...** of any layer as needed in the **Layer Actions** drop-down menu.

**Note:** Running an analysis on an annotation layer combines all results for the annotation regions in that layer into a single output. To analyze annotation regions separately, create separate annotation layers.

**Toolbar**

Annotations tools are displayed in the bottom right corner of the viewing window. Select a tool by left-clicking on the button. Blue shading indicates the tool is active. Hovering over a tool will pull up an abbreviated description of the tool.

- **Toggle Markup** – Toggles the analysis results on and off. Hover over this button and from the Toggle Action drop-down menu select Analysis Markup or Classifier Markup to move between the analysis and classifier markup overlays. Move the transparency slider to the right to increase the transparency of the active markup layer. For more information, see the Running the Analysis and Results sections.
- **Pan** – Navigate around the image. Left-click and hold down the left mouse button and drag to move the field of view.
- **Brush** – Draw new annotations or modify existing ones. Left-click and drag to draw the annotation. Release the mouse button to complete the annotation. Modify previously drawn polygons by clicking the annotation to highlight. Navigate the reticle (_intersection) cursor to overlap the line. Increase or decrease the size of the reticle using the [ and ] keys on the keyboard. Left-click and drag to change the boundary. Aligning the cursor inside of the annotation boundary will push out the annotation boundary, while aligning the annotation cursor outside of the annotation boundary and dragging will push in the annotation boundary.
- **Pen** – Draw new annotations or modify existing ones. Left-click and drag to draw the annotation. Release the mouse button to complete the annotation. Pen annotations are modified by clicking on the line and redrawing while holding down the left mouse button.
- **Exclusion Pen** – Draw annotation regions to be excluded from analysis. Left-click and hold down the mouse button and drag to draw the exclusion line. Release the mouse to finish the annotation. Exclusion annotations appear as black dashed lines. Exclusion pen annotations are modified by clicking on the line and redrawing while holding the left mouse button.
- **Magnetic Pen** – Automatically outline tissues or regions of tissue which have a well-defined edge. After selecting the magnetic pen tool, left-click near the edge of the tissue to annotate and move the cursor along the tissue edge. The edge must be within the reticle (.toDouble) to be identified. Increase or decrease the size of the reticle using the [ and ] keys on the keyboard. The tool will automatically find the nearest edge within the reticle as the mouse moves. While blue, the line is active and influenced by the cursor location. Once the line turns yellow, the line is locked into place. Left-click to change the active blue line to a yellow locked line at any time. Hit the space bar to finish the annotation. Annotations drawn with the magnetic pen are amended with the pen or brush tools.

- **Flood** – Automatically outlines areas of tissue with similar RGB values. Hold down the left mouse button while moving the reticle (.toDouble) cursor inside the tissue boundaries until the desired area is selected. Increase or decrease the size of the reticle using the [ and ] keys on the keyboard. If too much area is selected, use **Ctrl**+Z to shrink the selection. Annotations drawn with the flood tool are amended with the pen or brush tools.

- **Rectangle** – Draw a rectangular annotation. Hold down the left mouse button and drag to draw the annotation. Release the mouse to finish the annotation. Hold down the **Shift** key to create a square.

- **Ellipse** – Draw an elliptical annotation. Hold down the left mouse button and drag to draw the annotation. Release the mouse to finish the annotation. Hold down the **Shift** key to create a circle.

- **Pin** – Left-click to place a pin marker anywhere in the viewing window. To move a pin, select the annotation and use **Ctrl**+M, then left-click to place in new position.

- **Ruler** – Measure the distance between two points on the image screen. Left-click on the starting point and hold down the mouse button and drag to draw the annotation. Release the mouse to finish the ruler line. Resulting measurements are recorded in the annotations pane. A measurement of ‘0.0 µm’ is displayed if the image resolution is not set. Hold down the **Shift** key to create a straight line.

- **Channels** – Collapse or expand fluorescent channel box. The channel box allows users to turn channels on/off, toggle between emittance/absorption mode, adjust channel gamma values for image viewing, and change channel colors. *Only visible for fluorescent images.*

- **Snapshot** – Take a snapshot of the current viewing window. Any annotations or analysis markup visible in the viewing window will be saved in the snapshot. In the pop-up window, name the image, select the file destination, and choose to save the snapshot as a jpg or tif file.

### Annotation Modification

Annotations can be copied, pasted, moved, rotated or deleted. Left-click on any annotation, either in the viewing window or the annotations pane, to select it. Select multiple annotations by holding down the **Ctrl** key while clicking. Right-click on an annotation to access the annotation options drop-down menu: **Copy**, **Move**, **Rotate**, and **Delete** selected annotations or **Paste** copied annotations to another area or layer in the same image. Alternatively, annotations can be copied from one image and pasted to a different image. This may be useful to create identical annotations on serial sections. After selecting **Move** or **Rotate**, use the mouse to move or rotate the annotation to the new position and left-click to complete the annotation modification.

Annotations can also grow and shrink. Left-click on any annotation to select it. Right-click on an annotation to access the annotation options drop-down menu. Select **Grow** to make an annotation larger. Select **Shrink** to make an annotation smaller. Growing or shrinking an annotation will also smooth the annotation line.

Previously drawn annotations can be changed back and forth between inclusion and exclusion regions. Right-click on an annotation to access the annotation options drop-down menu. Select **Invert** to change an exclusion region to an inclusion region or change an inclusion region to an exclusion region.

Layers of annotations can be modified together using the Layer Actions drop-down: layers can be made visible, renamed, color, imported, exported and deleted.
Annotations Manager
Annotations layers are modified in batch from the Studies tab. Select the images with annotations to be modified in the Slide Pane and click on the Image Actions drop-down. Alternatively, right-click selected images to view the same menu. Select Manage Annotations to bring up the Annotations Manager window. The window displays all annotations from all layers of the selected images. To sort annotations, click the column header to sort in ascending order. Click again to sort in descending order. To sort by category, hover over the column header and click the filter icon, then choose the desired category from the drop-down menu. See Filter Object Data for more information on custom filters. To group annotations, drag column header to the box at the top of the window.

Once the group of annotations to be modified is selected, click the Actions drop-down menu. Rename, toggle visibility, change color, or delete selected annotations.

Import & Export
Annotations can be exported to a specified file location. Exporting automatically includes all annotation layers currently saved on the image. On the Layer Actions drop-down, select Export and choose the destination file, name and Save. The annotations will be saved as an .annotations file. This may be useful to create identical annotations on serial sections.

Annotations can be imported from the saved file location on any image by selecting Import from the Layer Actions drop-down menu. Hamamatsu(.ndpa) and Aperio(.xml) annotation file formats are also supported for imports.

Annotation Shortcuts
Alt: Create a new annotation layer
Ctrl: Make an annotation negative when used with the pen, brush, magnetic pen, flood, ellipse, or rectangle tools. Selects multiple annotations with pan tool.
Shift: Make a circle or square when used with the rectangle or ellipse tool
Delete: Delete selected annotation
Spacebar: Turn off the magnetic pen tool in magnetic pen mode
[ or \]: Expand/contract reticle (⌘) in brush, magnetic pen, or flood mode
Ctrl+A: Select all annotations on an image
Ctrl+C: Copy selected annotation
Ctrl+D: Paste selected annotation(s) to same direct XY coordinates
Ctrl++: Grow annotation
Ctrl+-: Shrink annotation
Ctrl+F: Fill/unfill annotation color
Ctrl+I: Invert annotation (toggle between inclusion and exclusion)
Ctrl+M: Move selected annotation
Ctrl+Alt+J: Combine selected annotation regions
Alt+B: Toggle visibility of all annotation layers
Alt+C: Change current annotation layer’s color
Alt+N: Go to next annotation layer
Alt+P: Go to previous annotation layer
Alt+Q: Quick annotator shortcut
  Pressing it once pops up a list of the most recently used annotator tools
  Continue to press Q while holding down the Alt key to move selection through the list
Alt+R: Rename current annotation layer
Alt+V: Toggle current annotation layer visibility
Ctrl+S: Saves selected annotation changes. A pop-up window will indicate ‘annotations saved’
Ctrl+V: Paste a copied annotation
Ctrl+Y: Redo last undo
Ctrl+Z: Undo last drawn annotation or annotation modification
  Undo one level of flood in flood mode

**Manual Counter**
Count objects in an annotation layer by manually clicking on each one.
- Click **Tools** from the navigation menu.
- Select **Manual Click Counter Start** from the drop-down menu.
- Left-click to count an object. A black cross-hair will appear around the counted object.
- Left-click on the center of the cross-hair again to delete it.
- Use the **spacebar** to pan to another area of the current annotation.
- Use the **delete** key to remove the previous object.
- To terminate the click counter, click **Tools** on the navigation menu and select **Manual Click Counter Stop** from the drop-down menu.
- If another session is started on the same image later, a popup window will ask the user to **Edit Current Session** or **Start New Session**.

*Note:* To use the manual counter, an annotation region must be drawn.

Results, including the total count and object coordinates, are listed under the Results tab and may be spatially plotted in HALO or exported to a spreadsheet for further analysis. Highlight the data of interest and hold down **Ctrl+C** to copy the selected results or click the right mouse button and select **Copy** from the drop-down menu. Open a spreadsheet and hold down **Ctrl+V** or right-click in a cell and select **Paste** from the drop-down menu.

Delete the results or change the current results layer to remove the displayed boxes.

**Advanced Annotation Tools**
Left-click on an annotation to select it. Right-click to access the advanced annotations menu in the drop-down menu.
If no annotation is selected, the menu will be greyed out.
Layer Thickness
Measure distance between two annotation lines at regular intervals.

- Draw annotation lines at the top and bottom of the area to be measured in the same annotation layer.
- Select both annotations by holding down the Ctrl key while left-clicking on each of them.
- Right-click to bring up the annotation options menu.
- Select Advanced > Layer Thickness....
- In the pop-up window, select which line to use as the baseline and adjust the interval and smoothing as desired.
- Click the OK button to apply.
- Thickness measurements are recorded to a new annotation layer.
- Copy and paste measurements into a spreadsheet for further analysis.

Margins
Build margin annotations from selected annotations.

*Note:* This tool is intended for open polyline annotations. Concentric Partitioning should be used for closed polygons.

- Select the annotation to partition by left-clicking on the annotation.
- Right-click to bring up the annotation options menu.
- Select Advanced > Margins....
- In the pop-up window, select the number of margins and margin thickness in microns.
- An offset for the margin start location is added by typing into the text box or moving the slider by clicking and dragging with the mouse.
- An offset between the margins is applied by typing into the appropriate box.
  - Positive values shift the margin up or right.
  - Negative values shift the margin down or left.
- Click the OK button to apply.
- A new annotation layer is created for each margin.

Concentric Partitioning
Subdivide the selected annotation into concentric bands/zones.

*Note:* This tool is intended for closed polyline annotations. Margins should be used for open polygons.

- Select the annotations region to partition by left-clicking on the annotation.
- Right-click to bring up the annotation options menu.
- Select Advanced > Partitioning (Concentric)....
- In the pop-up window, select the partition direction (inward, outward, or around).
- Select the number of zones and the fixed interval between zones.
- Select or deselect *Add exclusion regions* to determine if analysis excludes or includes inner zones.
- Click the OK button to apply.
- A new annotation layer is created for each partition.

Tiled Partitioning
Subdivide the selected annotation into square tiles of a uniform size.

- Select the annotations region to partition by left-clicking on the annotation.
- Right-click to bring up the annotation options menu.
- Select Advanced > Partitioning (Tiled)....
In the tiled partitioner pop-up window, adjust the tile size, space between tiles (optional), and offsets (optional).
- The random reduction option reduces the number of tiles by an input percentage.
  - The number of tiles generated, and the number eliminated are listed at the bottom of the pop-up.
  - Click the resample box to resample the tiles.
- Click the OK button to apply.
- A new annotation layer is created for each tile.

**Join**
Join multiple annotations into a single annotation.
- Select the annotations regions to join by left-clicking on each of the annotations while holding down the CTRL key.
- Right-click to bring up the annotation options menu.
- Select Advanced > Join....
- In the pop-up window, decide to retain the original regions or not by clicking the Yes or No button, respectively.
- The joined annotations will appear in a new layer labeled “Combined.”

### 5. Image Registration
Align two or more images of serial sections.

- Open two or more images which are serial sections from the same tissue block.
- View the images side by side. Right-click on an image tab and select Tile All Tabs Vertically.
- From the navigation menu click Tools.
- Select Image Registration > New Registration... from the drop-down menu.
- An image registration pop-up window containing a list of currently open images will open.
  - Change the images selected by clicking on the ... button to select a different image or use the Add Images button to add additional images to the registration.
  - Enter a stain name for each slide. A stain name is required for registration.
  - Use the Tab key to quickly move through stain names.
- Click the OK button to begin registration.
- A popup with a progress bar will display the progress of image registration.
- The Stop button will end the registration before the alignment completes; however, any registration completed before pressing the Stop button is applied to the images.
- Registration is complete when the window closes.

After registration, image viewing is synced between registered images. The pointer appears in corresponding registered images as a small circle.

Image registration may be edited after completion to change image names or delete images. From the top navigation menu, click Tools > Image Registration > Edit Registration.... Delete images from the registration group or modify image names.

To end synchronized navigation between registered images when finished, uncheck Synchronize Navigation under Image Registration in the Tools drop-down menu. Closing one of the registered images also ends synchronized navigation.

To open a set of images currently registered with an image selected in the viewer, click Tools > Image Registration > Open Registered Images.... This will close any images not registered with the set and automatically synchronize navigation. No more than 10 registered images may be opened in the viewer at one time to prevent system lag.
**Batch mode**
Align batches of two or more images of serial sections.

- Go to the Studies tab.
- In the image pane, select the first set of images to register.
- From the *Image Actions* drop-down menu, select *Register*.... A batch registration window will open.
- Type a stain name for each slide. Click the *Register* button to add the set to the queue.
  - Left-click on a slide label to rotate it 90 degrees.
  - Use the *Tab* key to quickly move to the next stain box.
- Image registrations in progress will show up in the lower *Queue* portion of the window. A registration job occurs for every pair of images.
- For the next set of images to be registered, left-click and drag the thumbnail of each of the next images into the appropriate stain box in the batch registration window.
- To remove an image, right-click on a stain box and select *Vacate image*.

![Batch Registration](image)

Figure 10 – Batch image registration mode. Four serial sections are selected for registration. The fourth slide requires a stain name prior to registration.

- To remove the stain box, right-click on the stain box and select *Remove Stain*.
- Once registration completes, open the images in a tiled view and click *Tools > Image Registration > Synchronize Navigation* to view the registration between image sets.

**Edit Registration with Landmarks**
If the automated image registration is insufficient for your analysis. Image registration may be edited by adding landmarks to the images.

- View the registered images side by side. Right-click on an image tab and select *Tile All Tabs Vertically*.
- From the navigation menu click *Tools*.
- Select *Image Registration > Landmarks*... from the drop-down menu.
• The landmark window will pop up with instructions. A new pushpin tool (📌) is now available in the annotations toolbar and all other tools are disabled in this mode.
• To add a marker left-click the pushpin tool to enable it and click on the landmark of interest in the first registered image. Another marker will appear in the corresponding registered images. Move the corresponding markers on the other images using the pan tool to match up the landmarks between the images.
• Click the Apply button to incorporate these landmarks into the registration.
• Once your satisfied with the results, close the landmark window by left-clicking the OK button to end Landmark Mode.

Annotations on Registered Images
Annotations drawn on a synchronized registered image will automatically be drawn on overlapping regions of corresponding registered images.

Alternatively, previously drawn annotations can be copied to registered images. Right-click on the annotation of interest. From the drop-down menu select Advanced > Copy to Registered. To copy annotations to registered images, all registered images must be open, and navigation synchronized.

Advanced Settings
Basic Registration settings are ideal for most serial section registration jobs. Select, the Serial Stain Registration settings from the drop-down if registering two images of the same piece of tissue. Click on the Settings button to view and change detailed options.

• Image Matching – If checked, the registration will begin with an attempt to match the two images. If the registration is producing undesirable results on a pair of images, try disabling image matching.
• Include Consistency Phase – If checked, the registration will favor creating transforms that are approximately inverses at moderate detail levels. This may not be necessary if the images are close matches.
• Include Similarity-Only Phase – If checked, the registration will exclusively use mutual information for each transformation as the registration shifts to finer details. May increase the difference between the primary and inverse transforms.
• High-Resolution Registration – If checked, the registration will continue to finer details. This may be useful for serial staining, where the individual cells match across slides. Considerably increases the registration time and size.
• Single-Channel Registration – If checked, you must select a single channel for every multichannel image (DAPI is default). This option can improve registration considerably if there is a matching channel across all images.

Default settings:
• Basic Registration – Image Matching, Include Consistency Phase, Include Similarity-Only Phase
• Serial Stain Registration – Include Consistency Phase, Include Similarity-Only Phase, High-Resolution Registration

6. **Figure Maker**

Quickly create figures for presentations or publications.

• From the navigation menu click **Tools**.
• Select **Figure Maker** from the drop-down menu.
• The figure maker window will pop up.
• Under the layout options, adjust the number of rows and columns in the figure using the top two text boxes.
• Change the border width and spacing between frames using the next two text boxes.
• Click on a frame in the figure to begin adding images.
  o The red border and unlocked symbol indicate the frame will display the active field of view in the viewing window. Left-click on the frame to lock the view in place.
  o The green frame border and locked symbol in the corner indicates the frame is locked.
  o To unlock and select another view, left-click in the frame again.
  o Capture fields of view at any magnification or toggle the markup image using the toggle analysis button (🔍) on the left side of the annotations toolbar.
  o When a frame is unlocked, the slide label (if available) is captured in the figure frame by clicking the **Capture Label** button.
  o When a frame is unlocked, the TMA Heatmap (if open) is captured in the figure frame by clicking the **Capture TMA Heatmap** button.
• Repeat the capture process for each frame until complete.
• Under the options category in the pop-up window, add scale bars and reference frames by checking/unchecking the corresponding boxes.
  o Reference frames indicate the field of view captured in the frame immediately to the right.
  o Reference frame and scale bars update automatically if an image is changed.
• Add alpha, numeric, alphanumeric, or custom labels to each thumbnail by selecting the desired option from the label drop-down menu.
  o For custom labels, click on the “Click to Edit” text that appears in each frame to insert custom text.
  o Enter the custom label into the pop-up window and click the **OK** button.
  o Repeat for each frame.
• Change label fonts by clicking the **Font...** button. Select the font, style, and size in the pop-up window.
• The label background options allow modification of the label background for the labels or scale bars by selecting/deselecting full length, toggling between white and black fade using the **White Fade/Black Fade** button, and by changing the opacity by moving the slider.
• Click the Save As... button to save the image.
• In the pop-up window, select the desired image size units from the first drop-down menu.

![Figure Maker Example](image)

Figure 12 – Figure maker example. This example shows a 2x4 figure with scale bars, reference frames, and alphanumeric labels turned on. The red box and lock symbol indicate frame 2b is unlocked.

• Select the width and height of the image in the next section.
  o The default is the maximum possible size.
  o Click the Reset to Max Possible to reset the size to the maximum possible size.
• Finally select the image resolution and units.
• When finished, click the Save As... button.
• In the pop-up window, select the name, location, and file type (jpg, tif, or png) for the image file.
• Click the Save button to save the figure.

*Note:* The saved image file is no longer able to be modified.

### 7. Available Algorithms

Many algorithms are available for purchase. Analysis instructions and settings vary for each algorithm module. For algorithm specific tuning instructions please see the step-by-step guide for that specific module in the Help menu. Contact support@indicalab.com for additional questions. Browse our complete module list at indicalab.com/products/.

### 8. Running the Analysis

**Load Analysis Settings**

• Go to the Analysis tab to begin a new algorithm tuning session.
• Click on the Setting Actions button.
• Select Load... from the drop-down menu.
• A window containing all available algorithms will pop up.
  o Default Settings tab – All HALO algorithms installed on the workstation will be visible under the default settings tab. Default parameter settings are always the same. If tuning for a new stain, load the default parameters.
  o Saved Settings tab – Previously saved settings are found under the saved settings tab. Settings are saved to a specific study folder. In the drop-down menu of the Load from Study option, select All Studies to view all accessible saved analysis settings.
  o Import – Load previously exported settings by clicking the Import Settings button.
• Click the desired algorithm name to highlight the module.
• Click the Select button to load the settings.

Import Analysis Settings
• In the Analysis tab, click on the Setting Actions button.
• Select Load Settings from the drop-down menu.
• Click the Import Settings button near the bottom left corner of the pop-up window.
• In the next pop-up window, identify the appropriate ‘.analysissettings’ file and click the Open button.
• A pop-up window will instruct the user to enter a unique settings name.
• Click the OK button to load those settings.

Adjust Analysis Parameters
Go to the Analysis tab to begin a new algorithm tuning session. In the parameter pane, scroll down to see the parameter groups available for tuning. Click on a parameter group title to display the individual parameters. Displayed groups and parameters vary based on the algorithm. For the selected group or parameter, a detailed description appears in the description pane.

Note: Right-click on a group or parameter name and select Ungroup inputs to see all parameters in a single list. Similarly, right-click on an ungrouped parameter name and select Group inputs to see grouped parameter settings.

Figure 13 – Analysis window example. This example shows the analysis tab with the Cytonuclear module settings loaded. The real-time tuning and the color selection windows are open in this screenshot.
To begin the tuning, go to the **Analyze** drop-down button at the top of the parameter pane and select **Real-time Tuning** from the drop-down menu. The real-time tuning window displays the results of parameter changes in real time. Change the size of the tuning window by clicking and pulling on the corners. Pan across the image to see real-time tuning for different regions. Click on the toggle analysis button ( ) to the left of the pan tool turn on and off the markup image. Hover over the toggle button to adjust the transparency of the markup image using the transparency slider. Change the toggle action with the drop-down menu. The real-time tuning window displays the markup image type selected in the output image parameter. Each parameter is changed via a text box or drop-down menu. For text boxes, parameter values are changed by typing into the individual text boxes or by using the slider option. Access the slider by clicking the ... button to the right of the text box. The slider is moved by clicking and dragging or using the arrow keys on the keyboard. For drop-down menus, click on the box and select the appropriate value. The real-time tuning window displays the results of changing these parameter values in real-time.

Bright field algorithms use color deconvolution to separate chromogenic stains for analysis. The RGB optical density (OD) values must be specified for each stain. To specify these values, the color selection window is launched by clicking on the colored box next to the stain of interest. Click on a region of the image in the viewing window corresponding to the stain of interest. Move the pixel zoom slider to the right to zoom in until 9 to 16 pixels are displayed in the zoomed box. Use the grey boxes on each side of the zoomed box to move one pixel at a time in each direction. Click the **OK** button to save the average RGB for these pixels. Click the **No Stain** button to remove the stain from analysis. Click the **Gray/Black** button to select RGB values of 1, 1, and 1. Repeat the process for all stains in the module.

Once all parameters are set, save the parameter settings.

**Save Tuned Analysis Settings**

- Under the Analysis tab, click on the **Setting Actions** button.
- Select **Save...** from the drop-down menu.
- In the pop-up window, name the settings.
- Select the appropriate study to save the settings in the **Save to study** drop-down.
- Click the **Save** button.

Once parameter settings are saved, images may be analyzed in batch mode.

**Export Analysis Settings**

- Under the Analysis tab, click on the **Setting Actions** button.
- Select **Export...** from the drop-down menu.
- In the pop-up window, select the name and location for the export file.
- Click the **Save** button.
- A pop-up window will report the file was successfully created.
- Click the **OK** button.

**Live Mode Analysis**

In the Analysis tab, select how to analyze an image with one of the following methods from the **Analyze** drop-down menu.

- **Field of View** analyzes the area visible in the viewing window.
- **Annotation Layer** analyzes the annotation region or regions in the currently selected layer.
- **Entire Image** analyzes the entire image.

For large area analyses, the analysis jobs window will pop up to show the progress of the analysis. Image tiles currently being analyzed are shaded yellow and orange. The tiles already analyzed are shaded green. In the analysis
queue window, cancel analysis jobs by clicking **Cancel** in the drop-down of the **Job Actions** drop-down button. When analyzing an image in live mode, the analysis job must finish before performing any other tasks in HALO.

Quantitative image analysis results are shown in the Results tab. For more information, see the Results section.

**Batch Mode Analysis**

Batch mode analysis allows for analysis of multiple images or annotation layers with the same analysis settings. Previously saved settings are required to run batch mode analysis. Unlike live mode analysis, it is possible to simultaneously perform other tasks in HALO (tune, save, export, etc.) when analysis is launched in batch mode.

- In the Studies tab, select the images to analyze by left-clicking. Select multiple images by holding down the **Ctrl** key while clicking file names.
- In the **Image Actions** drop-down menu, select **Analyze…**
- In the pop-up window, choose the saved analysis settings from the list and whether to analyze the entire image or annotations on one or all layer(s).
- Click the **Analyze** button.
- The **Analysis Queue** window will pop up to show the batched analysis jobs.
  - In the analysis queue window, cancel or delete analysis jobs by highlighting the job and clicking **Cancel** or **Delete** in the drop-down menu from the **Job Actions** button.
  - Alternatively, change the priority of a job by selecting **Job Actions > Change Priority** and select highest or lowest for the highlighted job.

**9. Results**

Summary data is displayed for every analysis. Object data is present if the analysis is run with the store object data parameter changed to ‘True’. Analysis results from previous jobs are opened from the drop-down menu above the summary data pane in the Results tab.

**Summary Data**

Summary data appears under the Results tab in the summary data pane on the top left side panel. The data generated varies based on the module used in the analysis.

**Object Data**

If enabled, object data appears under the Results tab in the object data pane on the lower left side panel. Each row in the object data window corresponds to an object in the markup image. Click on any object in the image and the corresponding object will be highlighted in the table. Alternatively, click on any line in the table and the corresponding object will be highlighted in the image. The object is highlighted in the viewing window with a black or white box. Toggling the analysis markup off may improve the visibility of the box. Select multiple objects by holding down the **Ctrl** key and clicking on the object of interest in the image or the table.

To delete analysis results, select the desired results from the drop-down list near the top of the tab and click on the **Results Action** button. Select **Delete…** from the drop-down menu. **Delete All…** or **Delete All But Current…** are additional options.

To recover parameter inputs from a previous analysis run, select the desired results and click on the **Results Action** button. Select **Reload Inputs** from the drop-down menu.

Left-click and drag the **Object Data** tab to move the table to a separate viewing window or on top of the Summary section to create tabbed groups. The move is persisted through the session but ultimately temporary. Closing and reopening HALO will reset the layout.
Sort Object Data
The object data table can be sorted. Left-click the column heading of interest to sort the data in ascending order. Left-click the column heading again to sort the data in descending order.

![Image of sorted object data]

Figure 14 – Results window example. This example shows the Results tab after an analysis was completed with the object data turned on to obtain individual object data. Whole slide analysis summary data is shown in the summary data pane. An automatically generated histogram is shown in the plot pane. The object data pane contains information about individual cells. This example shows a single cell, highlighted by a black box and the corresponding numerical data in highlighted grey in the object data window.

Filter Object Data
To filter object data, left-click on the funnel icon (▼) that appears in the upper right corner of the column heading when the pointer hovers over the column heading. From the drop-down menu, select a listed value to only include objects with a value equal to the value shown. Alternatively, select (Custom) to bring up the custom autofilter pop-up window. Enter desired logic functions into the pop-up. Click the OK button to apply the filter.

If a filter is applied, the funnel icon above the filtered column changes to blue (▼) and the filter is listed at the bottom of the object data window.

![Image of AutoFilter pop-up window]

Figure 15 – AutoFilter pop-up window.

To delete the filter left-click the X button near the name of the filter in the lower left corner of the object data window. Alternatively, from the column heading filter drop-down menu, select (All) to remove a filter. Inactivate a filter by unchecking the box in the name of the filter in the lower left corner of the object window.
Manage multiple filters with the **Edit Filter** button in the lower right corner of the object window. The button is only visible if one or more filters is applied. Click on the **Edit Filter** button to create logic gates for multiple filters.

**Save Object Data Filters**

Save Object Data filters for later use on additional images or at later time points. Under the **Object Actions** drop-down, choose **Filter Options**. Select **Save** and type in a descriptive name for the filter settings. To access these saved settings, use the **Object Actions** drop-down, select **Filter Options** and click **Load**. In the Load Object Data Filter window, search for the desired filter by name, or scroll through all previously applied filters. Select the desired filter from the list to highlight, then click **Load**.

**Export Data**

Export data out of HALO and open it in different software, such as an Excel spreadsheet. Basic export enables summary or object results from a single image to be exported. Batch mode export allows analysis results from multiple images to be exported in one step. Advanced export generates an analysis summary document in addition to exporting annotations, analysis settings, classifiers, plots, summary analysis results, and object analysis results.

**Basic**

To export summary data, select all objects in the summary data table by clicking a table row and pressing **Ctrl+A**. To copy the data, press **Ctrl+C** or right-click in the summary window and select **Copy**. The data can then be pasted directly into a spreadsheet using **Ctrl+V** or by right-clicking in the spreadsheet and selecting **Paste**.

To export object data, select all objects in the summary data table by clicking a table row and pressing **Ctrl+A**. Select **Export…** from the **Object Actions** button drop-down. In the pop-up window, name the export file and select the file location. The .csv file can be opened by a spreadsheet or statistics software program. Alternatively, the selected data can be copied using **Ctrl+C** or by right-clicking a cell in the table and selecting **Copy**. The data can then be pasted directly into a spreadsheet using **Ctrl+V** or by right-clicking in the spreadsheet and selecting **Paste**.

**Batch Mode**

To batch export analysis results, go to the Studies tab. Select the images to export analysis results. From the **Image Actions** drop-down menu, select **Export > Summary Analysis Data** or **Object Analysis Data**. Choose which analysis results to export in the next pop-up window: all results, results with input layer name, or a specific index (1, 2, 3, ..., Last). Index refers to the analysis run/job. Click the **Export** button. In the next pop-up window, name the export file.
name and select the file location. Results are saved as a .csv file which can be opened by spreadsheet or statistical software programs.

Advanced Export

Export analysis results, annotations, analysis settings, and classifiers in one step and automatically generate a report from the summary results.

- Go to the Studies tab.
- Select the image or images to generate a report.
- From the Image Actions drop-down menu, select Export > Advanced... to open the export manager window.
- In the Images section, select what type and the size of images to generate. The default generates a thumbnail for all the available image options. Images of the slide label, input image, analysis markup, classifier markup, and plots can be included. Check or uncheck the desired boxes to generate the desired image sizes. The last column in the image section estimates the size of the files created. The size of the thumbnail and mid-sized images can be modified by changing the default values in the Max Dimension text boxes.
- Results may be filtered in the Filter Results by Index section by 1st, 2nd, ..., last, or all.
- Under the Results Data section, the default is to generate .csv files for the summary data and object data. Object data may also be exported as Split Jobs and/or on a Registered XY coordinate system specified by the user via the pop-up box. A report document is also generated if Analysis Report (docx file) is selected. Uncheck these boxes to avoid generating these files.
- In the Other section, check the boxes to generate files for the annotations, analysis settings and classifiers. This generates .annotations, .analysissettings, and .classifier file types that may be imported into HALO for subsequent analysis.
- In the Folders section, designate a destination folder for the export analysis. The default is the C drive but click the Choose... button to select a different location. The template word document may also be changed in this section. Click the Reset button to restore the default HALO template.
- Click the Generate button in the lower right corner of the window.
- A pop-up window will ask to export the selected jobs or all listed jobs. Click Export Selected ONLY to export only the gray highlighted images. Click Export ALL to export all the images listed in the pop-up window.
- The Images Generated and Jobs Processed progress bars at the bottom of the window track the progress of the export.
- When finished the export manager window will close and the folder with the export files will automatically open.
- The folder contains a summary document with links to the individual image files embedded in the document in addition to all the individual exported files.

Note: Advanced Export requires Word 2010 or later.

Delete Results

Basic

To delete analysis results (both summary and object data), open the image of interest and click on the Results tab. From the drop-down list above the summary data window, select the job to delete. Click on the Results Action button to the right and select Delete... from the drop-down menu. Click the OK button to delete the results.

Alternatively, users may delete all but one job. From the drop-down list above the summary data window, select the job to keep. Click on the Results Action button to the right and select Delete All But Current... from the drop-down menu. Click the OK button to delete the results.
Batch Mode
To delete results from multiple images or delete multiple jobs for a single image, click on the Studies tab. In the image pane, left-click on the image of interest. To select multiple images, use the ALT or CTRL keys. Click on the Image Actions button and select Results... from the drop-down menu. In the pop-up window, select the runs of interest. Results may be sorted and filtered by image, analysis settings, object data, algorithm, region of analysis, queued time, or job index by clicking on the header. To select multiple jobs, use the ALT or CTRL keys. Once all jobs are selected, click the Results Action drop-down and select Delete to delete the results.

Create Plots
Spatial plots and histograms based on object data results can be created directly in HALO. To create a plot, open the image of interest and go to the Results tab. Object data is required to create histograms and spatial plots.

Individual Spatial Plots
- Click the Object Actions button in the object data window.
  - All object data in the object data window will be plotted. Apply data filters to select a subgroup of data to plot. See Sort Object Data for more information on filtering.
- In the drop-down menu, select Plot > Spatial Plot....
- In the pop-up window, type the name of the data point series.
- Click the OK button.
- The plot window will pop up.
  - A plot legend is present in the upper right corner of the plot area.
- In the plot pop-up window, type the appropriate title and subtitle into the text boxes in the upper left corner.
- Toggle plot layers on/off by checking/unchecking the box to the left of the plot layer name.
- To change the display order of the plot layers, right-click on the plot layer title and select **Move Up** or **Move Down** from the drop-down menu.
  - Move the plot layer up to move the layer to the top of the plot.
  - Move the plot layer down to move the layer to the bottom of the plot.
- Change the field of view in the plot area window.
  - Click in the plot area and use the mouse wheel to zoom in and out.
  - Left-click and drag to pan around the image.
  - Right-click on a data point to display the data point plot layer and XY coordinates.
- Click the save plot button ( ) in the upper left corner of the window to save the plot.
  - In the next pop-up window, type in a name for the plot.
  - The saved plot appears in the plot window of the Results tab.
  - To reopen the plot, left-click on the thumbnail in the plot window of the Results tab.
- Click the save plot snapshot button ( ) in the upper left corner of the window to take a snapshot of the plot.
  - In the next pop-up window choose the snapshot name, the file destination, and what type of file to save the image as.
  - Click the OK button.

Add Additional Plot Layers

- A new data point series:
  - In the main HALO window, apply data filters to select the next data point series or open an analyzed registered image. See Sort Object Data for more information.
Click on the Object Actions button in the object data window.
- In the drop-down menu, select Plot > Spatial Plot.
- In the pop-up window, type the name of the point series.
- Click the OK button.

- A previously drawn annotation layer:
  - In the plot pop-up window, click Add Plot Layer > From Annotation....
  - Select the appropriate annotation layer in the next pop-up window.
  - Click the OK button.

Edit Plot Layers
- Right-click on the plot layer title and select Properties from the drop-down menu.
- In the next pop-up window, change the layer name by typing in the Layer Name textbox.
- Alter the marker style by changing the Symbol (circle, square, diamond, or triangle), Pixel Size, or Color.
- To color the data series as a heatmap:
  - Check the Color Spectrum box.
  - Select the result of interest from the Weight Column drop-down list.
  - Move the Weight Clipping sliders by left-clicking and dragging to modify the spectrum minimum and maximum.
  - A legend is displayed to the right of the plot.
- Click the Apply button to apply the changes without closing the pop-up window.
- Click the OK button to apply changes and close the window.

Batch Spatial Plots
To plot data series from multiple images, click on the Studies tab. In the image pane, left-click on the image of interest. To select multiple images, use the ALT or CTRL keys. Click on the Image Actions button and select Results... from the drop-down menu. In the pop-up window, select the runs of interest. Results may be sorted and filtered by image, job index, analysis settings, or queued time by clicking on the header. To select multiple jobs, use the ALT or CTRL keys. Once all jobs are selected, click the Results Action drop-down and select Plot.... Add both annotation layers and data series via the Add Plot Layer drop-down menu. Once compete click the save button to save the plots with each of individual image analysis results.

Individual Histograms
- Click on the Object Actions button in the object data window of the Results tab.
- In the drop-down menu, select Plot followed by Histogram.
- In the pop-up window, type the series name into the text box, select the bar color from the drop-down menu and select the data column from the drop-down menu.
- The variables in the data column include all the columns in the object results window.
- Lastly select the number of bins to divide the data between.
Click the **Apply** button to preview the plot.

Click the **OK** button to apply the input settings and close the input window.

Type the plot title and subtitle into the corresponding text boxes in the plot window.

To modify the data series, right-click the plot layer name and select **Properties** from the drop-down menu to reopen the series window.

Clicking the save button ( ), saves the plot.
  - In the next pop-up window, type in a name for the plot.
  - The saved plot appears in the plot window of the Results tab.
  - To reopen the plot, left-click on the thumbnail in the plot window of the Results tab.

Clicking the snapshot button ( ), takes a snapshot of what is in the current plot window.
  - In the pop-up window, select the name and location of the output image.
  - Click the **OK** button.

![Figure 23 – Histogram plot window.](image)
10. HALO Shortcuts

**Arrows:** Viewer: pan image 90% in given direction  
TMA: move from one core to the next if TMA map is active  
Analysis: up/down moves parameter thresholds up/down when threshold bar is selected

**Delete:** Annotations: Delete selected annotation  
Studies: Delete selected image

**Escape:** Exit full screen mode

**F2:** Rename selected image

**F11:** Toggle full screen mode

**Shift:** Make a circle or square when used with the ellipse or rectangle tools

**Space:** Manual Click Counter: pans view to reveal another area of current annotation  
TMA tab: navigate to next TMA spot  
Viewer: Turn off the magnetic pen

[ and ]: Expand/contract reticle (шел) in brush, magnetic pen, or flood mode

**Alt:** Hold while drawing an annotation region to create a new annotation layer

**Alt+B:** Toggle visibility of all annotation layers

**Alt+C:** Change current annotation layer’s color

**Alt+N:** Go to next annotation layer

**Alt+P:** Go to previous annotation layer

**Alt+Q:** Quick annotator shortcut  
Pressing it once pops up a list of the most recently used annotator tools  
Continue to press Q while holding down the Alt key to move selection through the list

**Alt+R:** Rename current annotation layer

**Alt+S:** Phenotyper: toggle segmentation

**Alt+V:** Toggle current annotation layer visibility

**Ctrl:** Create negative annotation

**Ctrl+A:** Select all annotations, objects, images, etc. – depends on location of pointer when used

**Ctrl+B:** Toggle object boxes

**Ctrl+C:** Copy selected annotation

**Ctrl+D:** Paste selected annotation(s) to same XY coordinates

**Ctrl+E:** Toggle between analysis markup and classifier markup if both are present

**Ctrl+F:** Fill/unfill annotation color
HALO Shortcuts (cont.)

Ctrl+I: Invert annotation (toggle between positive and negative)

Ctrl+M: Move selected annotation

Ctrl+N: Next image (any changes to annotations in the previous image are automatically saved)

Ctrl+O: Open image

Ctrl+P: Open previous image (any changes to annotations in the previous image are automatically saved)

Ctrl+R: Toggle markup results on/off

Ctrl+S: Saves annotation changes
   A pop-up window will indicate that ‘annotations saved’

Ctrl+T: Fill/unfill classifier training region color

Ctrl+V: Paste selected annotation(s)

Ctrl+W: Close active image

Ctrl+Y: Redo last undo

Ctrl+Z: Undo last drawn annotation or annotation modification
   Undo one level of flood in flood mode

Ctrl++: Grow annotation

Ctrl--: Shrink annotation

Ctrl+0: Go to fit magnification

Ctrl+1: Go to 5% magnification

Ctrl+2: Go to 10% magnification

Ctrl+3: Go to 25% magnification

Ctrl+4: Go to 50% magnification

Ctrl+5: Go to 100% magnification

Ctrl+scroll: Zoom beyond image resolution

Ctrl+←: Rotate image 90 degrees

Ctrl+↓: Rotate image 180 degrees

Ctrl+→: Rotate image -90 degrees

Ctrl+↑: Reset image rotation

Ctrl+Alt+J: Combine selected annotation regions
11. HALO Viewer

1. **Studies tab**: This tab is for organization of images and batch analysis mode is access from here.

2. **TMA tab**: Tissue Micro Array caters for analysis of slides containing multiple tissue or cellular cores. Only available if purchased.

3. **Annotations tab**: Annotations allow you to identify specific regions to include or exclude from analysis.


5. **Study Sort**: Sort studies in ascending or descending order by creation date or alphabetical order.

6. **Classifiers tab**: Classifiers instruct the algorithm to delineate tissue based on its type [tumor, stroma etc.]. Only available if purchased.

7. **Analysis tab**: This tab is used to fine tune the analysis settings and load algorithms.

8. **Study Search**: Free text search for studies.

9. **Results tab**: Results summary and object results are located here.

10. **Refresh**: Refresh HALO (if part of a group license or Halo Link installation).

11. **Image Tab**: Open image tab (file name if unchanged).

12. **Slide Label**: Contains information about the sample.

13. **Main image viewer**: The main working area, displays images after opening.

14. **Thumbnail**: Used to rapidly navigate around the image, may be reduced in size or removed.

15. **Snapshot**: Take a snapshot of the current viewing window.

16. **Pin**: Place a pin marker anywhere in the viewing window.

17. **Ruler**: Measure the distance between two points on the image screen.

18. **Ellipse**: Draw an elliptical annotation.

19. **Rectangle**: Draw a rectangular annotation.

20. **Magnetic Pen**: Automatically outline tissues or regions which have a well-defined edge.

21. **Pen Tool**: Draw new polygon annotations or modify existing ones by drawing lines.

22. **Flood-Fill**: Automated tool to identify tissue boundaries using RBG pixel intensity and R-value.

23. **Exclusion Pen**: Construct annotation regions to be excluded from analysis.

24. **Brush Tool**: Draw new polygon annotations or modify existing ones using brushstrokes.

25. **Pan tool**: This allows you to pan around the image.

26. **Toggle Markup**: Toggles between the analysis markup overlay and classifier overlay. Adjust transparency of markup with the slider bar.

27. **Current Magnification**: Indicates the magnification of the viewing window.

28. **Zoom Slider**: Click and drag or jump to a specified zoom.

29. **Image Actions pane**: Images are organized and analyzed here.

30. **Studies pane**: Study folders are organized here.